
http://suratiundhiyu.wordpress.com/ Page 1 

 

EXCELL 
 
Simplifying the PV, NPV, and FV Functions of Excel 2003 

Using AutoFilter in Excel 2003 

Working with Multiple Excel 2003 Workbooks 

Deciphering Formula Errors in Excel 2000 

Creating Custom Number Formats in Excel 2000 

Printing Your Worksheet the Way You Want in Excel 2000 

Adding and Deleting Sheets in Excel 2000 

Changing the Color of a Sheet Tab in Excel 2003 

Formatting the X-Axis or Y-Axis of a Chart in Excel 2002 

Ordering Up Organizational Charts in Excel 2002 

Taming the Excel 2002 Task Panes 

Making Plotted Data Charts Easier to Decipher in Excel 

Comparing Excel 2003 Worksheets Side by Side 

Deciphering the Excel 2003 Custom Number Formats 

Password-Protecting an Excel 2003 File 

Get to Know AutoSum 

Calibrating Columns 

Getting Out Your Scissors and Glue in Excel 2003 

The Function of Formulas 

Opening Files with a Twist in Excel 2003 

Setting Up Document Recovery in Excel 2003 

Straightening Out the Sheets 

Creating Interactive Web Pages in Excel 

Using Data Entry Forms 

Document Recovery to the Rescue 

Some Sorta Order 

Adding a Legend to a Chart 

Audible Proofreading 

Stamping Out Errors with Text to Speech in Excel 2002 

Fooling Around with Format Painter 

Recording macros in Excel 

Password-Protecting an Excel 2003 File 

Saving a Static Web Page in Excel 2002 

Inserting Special Symbols 

Transient Toolbars 

 
 

 
 
Simplifying the PV, NPV, and FV Functions of Excel 2003 
 

http://suratiundhiyu.wordpress.com/


http://suratiundhiyu.wordpress.com/ Page 2 

 

Money! There's nothing quite like it. You can't live with it, you certainly can't live without it, and many of the 
spreadsheets that you work with exist only to let you know how much of it you can expect to come in or to pay out. 
Excel contains a fair number of sophisticated financial functions for determining such things as the present, future, 
or net present value of an investment; the payment, number of periods, or the principal or interest part of a 
payment on an amortized loan; the rate of return on an investment; or the depreciation of your favorite assets. 

The PV (Present Value), NPV (Net Present Value), and FV (Future Value) functions enable you to determine the 
profitability of an investment.  

Calculating the Present Value 

The PV, or Present Value, function returns the present value of an investment, which is the total amount that a 
series of future payments is worth presently. The syntax of the PV function is as follows: 

=PV(rate,nper,pmt,[fv],[type]) 

The fv and type arguments are optional arguments in the function (indicated by the square brackets). The fv 
argument is the future value or cash balance that you want to have after making your last payment. If you omit the 
fv argument, Excel assumes a future value of zero (0). The type argument indicates whether the payment is made 
at the beginning or end of the period: Enter 0 (or omit the type argument) when the payment is made at the end of 
the period and use 1 when it is made at the beginning of the period. 

Figure 1 contains several examples using the PV function. All three PV functions use the same annual percentage 
rate of 7 1/4 percent and term of 10 years. Because payments are made monthly, each function converts these 
annual figures into monthly ones. For example, in the PV function in cell E3, the annual interest rate in cell A3 is 
converted into a monthly rate by dividing by 12 (A3 ÷ 12) and the annual term in cell B3 is converted into equivalent 
monthly periods by multiplying by 12 (B3 x 12).  

 
 
Figure 1: Using the PV function to calculate the present value of various investments. 

Note that although the PV functions in cells E3 and E5 use the rate, nper, and pmt ($218.46) arguments, their 
results are slightly different. This is caused by the difference in the type argument in the two functions: the PV 
function in cell E3 assumes that each payment is made at the end of the period (the type argument is 0 whenever it 
is omitted), while the PV function in cell E5 assumes that each payment is made at the beginning of the period 
(indicated by a type argument of 1). When the payment is made at the beginning of the period, the present value of 
this investment is $0.49 higher than when the payment is made at the end of the period, reflecting the interest 
accrued during the last period. 

The third example in cell E7 (shown in Figure 1) uses the PV function with an fv argument instead of the pmt 
argument. In this example, the PV function states that you would have to make monthly payments of $3,883.06 for 
a 10-year period to realize a cash balance of $8,000, assuming that the investment returned a constant annual 
interest rate of 7 1/4 percent. Note that when you use the PV function with the fv argument instead of the pmt 
argument, you must still indicate the position of the pmt argument in the function with a comma (thus the two 
commas in a row in the function) so that Excel doesn't mistake your fv argument for the pmt argument. 

Calculating the Net Present Value 
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The NPV function calculates the net present value based on a series of cash flows. The syntax of this function is 

=NPV(rate,value1,[value2],[...]) 

where value1, value2, and so on are between 1 to 13 value arguments representing a series of payments 
(negative values) and income (positive values), each of which is equally spaced in time and occurs at the end of 
the period. The NPV investment begins one period before the period of the value1 cash flow and ends with the last 
cash flow in the argument list. If your first cash flow occurs at the beginning of the period, you must add it to the 
result of the NPV function rather than include it as one of the arguments.  

Figure 2 illustrates the use of the NPV function to evaluate the attractiveness of a five-year investment that requires 
an initial investment of $30,000 (the value in cell G3). The first year, you expect a loss of $22,000 (cell B3); the 
second year, a profit of $15,000 (cell C3); the third year, a profit of $25,000 (cell D3); the fourth year, a profit of 
$32,000 (cell E3); and the fifth year, a profit of $38,000 (cell F3). Note that these cell references are used as the 
value arguments of the NPV function.  

 
 
Figure 2: Using the NPV function to calculate the net present value of an investment. 

Unlike when using the PV function, the NPV function doesn't require an even stream of cash flows. The rate 
argument in the function is set at 8 percent. In this example, this represents the discount rate of the investment; 
that is, the interest rate that you may expect to get during the five-year period if you put your money into some 
other type of investment, such as a high-yield money-market account. This NPV function in cell A3 returns a net 
present value of $31,718.63, indicating that you can expect to realize about $1,719 more from investing your 
$30,000 in this investment than you would from investing the money in a money-market account at an interest rate 
of 8 percent. 

Calculating the Future Value 

The FV function calculates the future value of an investment. The syntax of this function is 

=FV(rate,nper,pmt,[pv],[type]) 

The rate, nper, pmt, and type arguments are the same those used by the PV function. The pv argument is the 
present value or lump-sum amount for which you want to calculate the future value. As with the fv and type 
arguments in the PV function, both the pv and type arguments are optional in the FV function. If you omit these 
arguments, Excel assumes their values to be zero (0) in the function. 

You can use the FV function to calculate the future value of an investment, such as an IRA (Individual Retirement 
Account). For example, suppose that you establish an IRA at age 43 and will retire 22 years hence at age 65 and 
that you plan to make annual payments into the IRA at the beginning of each year. If you assume a rate of return of 
8.5 percent a year, you would enter the following FV function in your worksheet: 

=FV(8.5%,22,–1000,,1) 

Excel then indicates that you can expect a future value of $64,053.66 for your IRA when you retire at age 65. If you 
had established the IRA a year prior and the account already has a present value of $1,085, you would amend the 
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FV function as follows: 

=FV(8.5%,22,–1000,–1085,1) 

In this case, Excel indicates that you can expect a future value of $70,583.22 for your IRA at retirement. 
 

  

 

 

Using AutoFilter in Excel 2003 
 

Excel's AutoFilter feature literally makes filtering out unwanted data in a data list as easy as clicking a button. When the cell pointer is 
located within any cell in your data list and you choose the Data --> Filter --> AutoFilter command from the Excel menu bar, the program 
adds drop-down buttons to each of the field names in the top row of the list, as shown in Figure 1.  

 
 

Figure 1: Employee data list with the AutoFilter feature turned on. 

 

When you click a drop-down button next to a field, Excel displays a menu that contains the following three items at the top of the menu: 

 All: Displays all records with an entry in that field 

 Top 10: Displays only the records with the top 10 values or in the top 10 percent 

 Custom: Opens the Custom AutoFilter dialog box, where you can specify multiple criteria for filtering the list by using either an AND or OR 
condition as well as criteria using logical operators, such as "is greater than," "is less than," "begins with," "ends with," and so on 

Following the Custom item, the field's drop-down list box displays all the unique entries in that field in ascending order (lowest to highest in 
numeric and date fields and A to Z in text fields). To filter out all the records in the list except those that contain a particular entry or value, 
click that entry or value on the field's pop-up menu. 
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For example, Figure 2 shows the Employee data list after selecting the entry, Accounting, on the Dept field's pop-up menu. As this figure 
shows, Excel has now hidden all the rows in the data list containing records where the entry in the Dept field was anything but Accounting, 
thus essentially filtering the list down to just those records for the employees who work in Accounting. 

 
 

Figure 2: Employee data list after filtering out all records except those where the Dept is Accounting. 

 

To redisplay the entire data list, you can click the (All) item at the very top of the Dept field's pop-up menu, or you can choose the Data --> 
Filter --> Show All command from the Excel menu bar. When you're finished filtering the data list, you can then remove the drop-down 
buttons from the field names by choosing Data --> Filter --> AutoFilter on the pull-down menus (this command acts like a toggle switch so 
that selecting it a second time turns it off). 

Making it to the Top Ten! 

When the AutoFilter feature is turned on, you can select the Top Ten item at the top of a field's pop-up menu to filter out all records except 
those whose entries in that field are at the top or bottom of the list by a certain number (10 by default) or in a certain top or bottom percent 
(10 by default). Of course, you can only use the Top Ten item in numerical fields and date fields; this kind of filtering doesn't make any sense 
when you're dealing with entries in a text field. 

When you click the Top Ten item on a numeric or date field's pop-up menu, Excel opens the Top 10 AutoFilter dialog box, shown in Figure 
3, where you can specify your filtering criteria. By default, the Top 10 AutoFilter dialog box is set to filter out all records except those whose 
entries are among the top ten items in the field by selecting Top in the drop-down list box on the left, 10 in the middle combo box, and Items 
in the drop-down list box on the right. If you want to use these default criteria, you simply click OK in the Top 10 AutoFilter dialog box. 
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Figure 3: Using the Top 10 AutoFilter dialog box to filter out all records except for those with the top ten salaries. 

 

You can also change the filtering criteria in the Top 10 AutoFilter dialog box before you filter the data. You can choose between Top and 
Bottom in the leftmost drop-down list box and between Items and Percent in the rightmost one. You can also change the number in the 
middle combo box by clicking it and entering a new value or using the Spin buttons to select one. 

Custom AutoFilter at your service 

You can use the Custom item on a field's pop-up menu to open the Custom AutoFilter dialog box, where you can specify more complex 
filtering criteria by using conditions with the AND and OR logical operators (called AND and OR conditions for short). When you click the 
Custom item on a field's pop-up menu, Excel opens the Custom AutoFilter dialog box, similar to the one shown in Figure 4. 

 
 

Figure 4: Using Custom AutoFilter to filter out records except for those within a range of salaries. 

 

Here, you select the type of operator to use in evaluating the first and the second condition in the top and bottom drop-down list boxes and 
the values to be evaluated in the first and second condition in the associated combo boxes. You also specify the type of relationship 
between the two conditions with the And or Or radio buttons (the And radio button is selected by default). 

When selecting the operator for the first and second condition in the leftmost drop-down list boxes at the top and bottom of the Custom 
AutoFilter dialog box, you have the following choices: 

 Equals 

 Does not equal 

 Is greater than 

 Is greater than or equal to 

 Is less than 

 Is less than or equal to 

 Begins with 
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 Does not begin with 

 Ends with 

 Does not end with 

 Contains 

 Does not contain 

Note that you can use the Begins with, Ends with, and Contains operators and their negative counterparts when filtering a text field — you 
can also use the question mark (?) and asterisk (*) wildcard characters when entering the values for use with these operators (the question 
mark wildcard stands for individual characters and the asterisk stands for one or more characters). You use the other logical operators when 
dealing with numeric and date fields. 

When specifying the values to evaluate in the associated combo boxes on the right side of the Custom AutoFilter dialog box, you can type in 
the text, number, or date, or you can select an existing field entry by clicking the box's drop-down list button and then clicking the entry on 
the pop-up menu. 

Figure 4 illustrates setting up filtering criteria in the Custom AutoFilter dialog box that selects records whose Salary values fall within a 
particular range of values. This example uses an AND condition to filter out all records where the salaries are below $40,000 and above 
$75,000 by entering the following complex condition: 

Salary is greater than or equal to 40000 AND is less than or equal to 75000 

You can also use the Custom AutoFilter feature to create an OR condition where records are displayed if they contain a value or an entry 
that meets either one of two conditions. For example, suppose that you wanted to see only the records in the data list where the location is 
Boston or Chicago. To do this, you open the Custom AutoFilter dialog box from the Location field's pop-up menu. Then, select the Equals 
operator in both condition drop-down list boxes, select Boston and then Chicago in the respective combo boxes, and then click the Or radio 
button to create the following complex condition: 

Location equals Boston OR equals Chicago 

 
 
 

 

Working with Multiple Excel 2003 Workbooks  

Adapted From: Excel 2003 All-in-One Desk Reference For Dummies  

Working with more than one worksheet in a single workbook is bad enough, but working with 
worksheets in different workbooks can be really wicked. The key to doing this successfully is just 
keeping track of "who's on first," and you do this by opening and using windows on the individual 
workbook files you have open. 

With the different workbook windows in place, you can then compare the data in different workbooks, 
use the drag-and-drop method to copy or move data between workbooks, or even copy or move 
entire worksheets. 

Comparing windows on different workbooks 

To work with sheets from different workbook files you have open, you manually arrange their 
workbook windows in the Excel Work area, or you choose the Window --> Compare Side by Side 
With command. If you have only two workbooks open when you choose the Compare Side by Side 
With command, Excel places the active workbook that you last opened above the one that opened 
earlier (with their active worksheets displayed). If you have more than two workbooks open, Excel 
displays the Compare Side by Side dialog box where you click the name of the workbook that you 
want to compare with the active one. 

 

http://suratiundhiyu.wordpress.com/
http://www.dummies.com/WileyCDA/DummiesTitle/productCd-076453758X.html


http://suratiundhiyu.wordpress.com/ Page 8 

 

 

If you need to compare more than two workbooks on the same screen, instead of choosing the 

Compare Side by Side With item on the Window menu, you choose Arrange and then select the 

desired Arrange option (Tiled, Horizontal, Vertical, or Cascading). Just make sure when selecting 

this option in the Arrange Windows dialog box that the Windows of Active Workbook check box is 

not selected (in other words, is empty of its check mark). 

Transferring data between open windows 

After the windows on your different workbooks are arranged on-screen the way you want them, you 
can compare or transfer information between them. To compare data in different workbooks, you 
switch between the different windows, activating and bringing the regions of the different worksheets 
you want to compare into view. 

To move data between workbook windows, arrange the worksheets in these windows so that both 
the cells with the data entries you want to move and the cell range into which you want to move them 
are both displayed in their respective windows. Then, select the cell selection to be moved, drag it to 
the other worksheet window, to first cell of the range where it is to be moved to, and release the 
mouse button. To copy data between workbooks, you follow the exact same procedure, except that 
you hold down the Ctrl key as you drag the selected range from one window to another. 

 

When you're finished working with workbook windows arranged in some manner in the Excel Work 

area, you can return to the normal full-screen view by clicking the Maximize button on one of the 

windows. As soon as you maximize one workbook window, all the rest of the arranged workbook 

windows are made full size as well. If you used the Compare Side by Side command to set up the 

windows, you can do this by clicking the Close Side by Side button on the Compare Side by Side 

toolbar or by choosing Window --> Close Side by Side (which replaces the Compare Side by Side 

With item on the Window menu). 

Transferring sheets from one workbook to another 

Instead of copying cell ranges from one workbook to another, you can move (or copy) entire 
worksheets between workbooks. You can do this with drag-and-drop or by using a variation on the 
standard cut-and-paste method, the Edit --> Move or Copy menu command. 

To use drag-and-drop to move a sheet between open windows, you simply drag its sheet tab from its 
window to the place on the sheet tabs in the other window where the sheet is to be moved to. As 
soon as you release the mouse button, the entire worksheet is moved from one file to the other, and 
its sheet tab now appears among the others in that workbook. To copy a sheet rather than move it, 
you perform the same procedure, except that you hold down the Ctrl key as you drag the sheet tab 
from one window to the next. 

To use the Edit --> Move or Copy Sheets command on the Excel menu bar to copy or move entire 
worksheets, you follow these steps: 

1. Open both the workbook containing the sheets to be moved or copied and the workbook 
where the sheets will be moved or copied to. 

Both the source and destination workbooks must be open in order to copy or move sheets 
between them. 

2. Click the workbook window with sheets to be moved or copied. 

Doing this activates the source workbook so that you can select the sheet or sheets you want to 
move or copy. 

3. Select the sheet tab of the worksheet or worksheets to be moved or copied. 

To select more than one worksheet, hold down the Ctrl key as you click the individual sheet tabs. 
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4. Choose Edit --> Move or Copy Sheets on the Excel menu bar. 

Doing this opens the Move or Copy dialog box, as shown in Figure 1. 

5. Click the filename of the workbook into which the selected sheets are to be moved or 
copied in the To Book pop-up menu. 

If you want to move or copy the selected worksheets into a new workbook file, click the (New 
Book) item at the very top of this pop-up menu. 

6. Click the name of the sheet that should immediately follow the sheet(s) that you're about 
to move or copy into this workbook in the Before Sheet list box. 

If you want to move or copy the selected sheet(s) to the very end of the destination workbook, 
click (Move to End) at the bottom of this list box. 

7. If you want to copy the selected sheet(s) rather than move them, click the Create a Copy 
check box. 

If you don't select this check box, Excel automatically moves the selected sheet(s) from one 
workbook to the other instead of copying them. 

8. Click OK to close the Move or Copy dialog box and complete the move or copy 
operation. 

 
 
Figure 1: Copying a worksheet to another workbook in the Move or Copy dialog box. 

 

  

 

 

Deciphering Formula Errors in Excel 2000  

Adapted From: Excel 2000 For Windows For Dummies  

Under certain circumstances, even the best formulas can appear to have freaked out after you get them in your 
worksheet. You can tell right away that a formula's gone haywire because instead of the nice calculated value you 
expected to see in the cell, you get a strange, incomprehensible message in all uppercase letters beginning with 
the number sign (#) and ending with an exclamation point (!) or, in one case, a question mark (?). This weirdness is 
known, in the parlance of spreadsheets, as an error value. Its purpose is to let you know that some element — 
either in the formula itself or in a cell referred to by the formula — is preventing Excel from returning the anticipated 
calculated value. 

The worst thing about error values is that they can contaminate other formulas in the worksheet. If a formula 
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returns an error value to a cell and a second formula in another cell refers to the value calculated by the first 
formula, the second formula returns the same error value and so on down the line. 

After an error value shows up in a cell, you have to discover what caused the error and edit the formula in the 
worksheet. Table 1 lists some error values that you may run into in a worksheet and explains the most common 
causes. 

Table 1: Error Values That You Can Encounter from Faulty Formulas 

What Shows Up 
in the Cell 

What's Going On Here?  

#DIV/0! Appears when the formula calls for division by a cell that either contains the value 0 or, 
as is more often the case, is empty. Division by zero is a no-no according to our math. 

#NAME? Appears when the formula refers to a range name that doesn't exist in the worksheet. 
This error value appears when you type the wrong range name or fail to enclose in 
quotation marks some text used in the formula, causing Excel to think that the text refers 
to a range name. 

#NULL! Appears most often when you insert a space (where you should have used a comma) to 
separate cell references used as arguments for functions. 

#NUM! Appears when Excel encounters a problem with a number in the formula, such as the 
wrong type of argument in an Excel function or a calculation that produces a number too 
large or too small to be represented in the worksheet. 

#REF! Appears when Excel encounters an invalid cell reference, such as when you delete a cell 
referred to in a formula or paste cells over the cells referred to in a formula. 

#VALUE! Appears when you use the wrong type of argument or operator in a function, or when 
you call for a mathematical operation that refers to cells that contain text entries. 

 

 

 

Creating Custom Number Formats in Excel 2000  

Adapted From: Excel 2000 For Windows For Dummies  

Excel has a bunch of special number formats that you can use, including formats for zip codes (and zip codes + 4), 
phone numbers, and Social Security numbers. But if none of the predefined number formats fits your bill, you can 
always resort to creating a custom number of your very own design. To create a custom number format, you must 
choose Custom as the Category in the Format Cells dialog box and then select the number format code that is 
closest to what you want from the Type list box and then, most often, edit this number format code in the Type text 
box. 

There's only one problem with doing this: Excel wasn't lying when it called them number format codes. All you see 
in the Type list box when Custom is the Category is a bunch of weird-looking codes composed of lots of #s, 0s, ?s, 
Ds, Ms, and Ys. Rather than work yourself into a lather (or, heaven forbid, do something nerdy like trying to 
decipher this gibberish), make life easier and focus your attention on the Sample area above the Type text box as 
you select various formats from the Format Codes list box. There, Excel shows how the value in the active cell of 
the selected range will look in the selected format. As soon as you see what you like, go for it by clicking the OK 
button or pressing Enter. 

 

In addition to choosing built-in formats by their number format codes, you can create your own custom codes by 
doing a little creative editing. Although you do have to use these junky number format codes (ugh) when 
performing this editing, you really don't have to be a rocket scientist to figure out how to do it. (Not that being a 
rocket scientist would hurt!) 

Rather than bore you with a lot of examples of custom number formats that even a computer nerd would have 
trouble staying awake through, here is a custom number format you may actually find quite handy in your 
worksheets — one that hides the display of any cell entry in the worksheet. (You can continue to see the entry on 
the formula bar when the cell pointer is in its cell.) You can then use your custom hidden format to temporarily hide 
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certain cell ranges that you don't want printed out or visible in your worksheet on-screen. 

To build the custom hidden number format, open the Format Cells dialog box (Ctrl+1), click Custom in the Category 
list box in the Number tab of the Format Cells dialog box, and then select General in the Type list box and replace 
this text with the following number format codes: 

;;; 

The custom hidden number format consists of just three semicolons in a row (with no spaces between them). Odd 
as this looks, these three semicolons tell Excel that it should display nothing for positive values, nothing for 
negative values, and, while you're at it, nothing for anything else in the cell. 

After entering the codes in the Type text box, click the OK button or press Enter to apply the custom format to the 
current cell selection. Custom formats are saved as part of the worksheet the next time you save the workbook file. 
(Remember, don't neglect that Save tool on the Standard toolbar!) 

When you apply this hidden format to cells, the cell display disappears in the worksheet (the contents still show up 
on the formula bar when you select the cell). To make hidden entries reappear, simply select the hidden cells, open 
the Format Cells dialog box, and select one of the other visible number formats (the General format, for example) 
and apply it to cells. 

 

Note that the custom number formats that you create are added to the bottom of the Type list box. This means that 
when you next open the Format Cells dialog box and select Custom in the Category list box of the Number tab, 
you may have to scroll through the Type list box all the way to the bottom before you can locate and select the 
number format codes that you're responsible for adding. 

 

 

 

 

 

Printing Your Worksheet the Way You Want in Excel 2000  

Adapted From: Excel 2000 For Windows For Dummies  

Printing with the Print tool on the Standard toolbar is fine, provided that all you want is a single copy of all the 
information in the current worksheet. If you want more copies, more or less data (such as all the worksheets in the 
workbook or just a cell selection within a particular worksheet), or you need to change some of the page settings 
(like the size of the page or the orientation of the printing on the page), then you need to print from the Print dialog 
box (shown in Figure 1). 
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Figure 1: The Print dialog box. 

Excel provides a number of ways to open the Print dialog box: 

 Press Ctrl+P. 

 Choose the File-->Print command on the menu bar. 

 Press Ctrl+Shift+F12. 

Printing in particular 

Within the Print dialog box are the Print range and Print what areas, where you can select how much of the 
information is printed, and the Copies area, where you can change the number of copies printed. Here's how you 
use these areas: 

 All: When the All radio button in the Page range section is selected, all the pages in your document will print. 
Because this is the default choice, you need to select it only after you have printed only a portion of the 
document, using the Page(s) radio button. 

 Page(s): Normally, Excel prints all the pages required to produce the information in the areas of the workbook 
that you want printed. Sometimes, however, you may need to reprint only a page or range of pages that you've 
modified within this section. To reprint a single page, enter its page number in both the From and To text boxes 
in the Page Range section or select these page numbers with the spinner buttons. To reprint a range of pages, 
put the first page number in the From text box and the last page number in the To text box. (Excel automatically 
deselects the All radio button and selects the Page[s] radio button in the Page Range section as soon as you 
start typing in the From or To text boxes.) 

 Selection: Select this radio button in the Print what section to have Excel print just the cells that are currently 
selected in your workbook. (Yes, you must remember to select these cells before opening the Print dialog box 
and choosing this radio button!) 
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 Active sheet(s): Excel automatically displays and selects this radio button and prints all the information in 
whatever worksheets are active in your workbook. Normally, this means printing just the data in the current 
worksheet. To print other worksheets in the workbook when this radio button is chosen, hold down Ctrl as you 
click the sheet's tab. To include all the sheets between two sheet tabs, click the first one and then hold Shift as 
you click the second tab. (Excel selects all the tabs in between.) 

 Entire workbook: Select this radio button in the Print what section to have Excel print all the data in each of the 
worksheets in your workbook. 

 Number of copies: To print more than one copy of the report, enter the number of copies you want to print in 
the Number of copies text box in the Copies section — or use the spinner buttons to select the required number. 

 Collate: When you collate pages, you simply make separate stacks of each complete report, rather than print all 
copies of page one, and then all copies of page two, and so on. To have Excel collate each copy of the report 
for you, select the Collate check box in the Copies section to put a check mark in it. 

After you finish choosing new print options, you can send the job to the printer by choosing OK or pressing Enter. 
To use another printer that's been installed for Windows 95 (Excel lists the current printer in the Name text box and 
all printers installed for Windows on the Name drop-down list), select the new printer on the Name pop-up menu in 
the Printer section at the top of the dialog box before you start printing. 

Setting and clearing the Print Area 

Excel includes a special printing feature called the Print Area. You can use the FilePrint Area-->Set Print Area 
command to define any cell selection on a worksheet as the Print Area. After the Print Area is defined, Excel then 
prints this cell selection anytime you print the worksheet (either with the Print button on the Standard toolbar or 
from the Print dialog box, using the File-->Print command or one of its shortcuts). Whenever you fool with the Print 
Area, you need to keep in mind that once defined, its cell range is the only one you can print (regardless of what 
options you select in the Print dialog box) until you clear the Print Area. 

To clear the Print Area (and therefore go back to the printing defaults established in the Print dialog box), you just 
have to select File-->Print Area-->Clear Print Area on the menu bar. 

You can also define and clear the Print Area from the Sheet tab of the Page Setup dialog box. To define the Print 
Area from this dialog box, insert the cursor in the Print area text box on the Sheet tab and then select the cell range 
or ranges in the worksheet (remembering that you can reduce the Page Setup dialog box to just this text box by 
clicking its minimize box). To clear the Print Area from this dialog box, select the cell addresses in the Print area 
text box and press the Delete key. 

 

  

 

 

 

Adding and Deleting Sheets in Excel 2000  

Adapted From: Excel 2000 For Windows For Dummies  

For some of you, the three worksheets automatically put into each new workbook that you start are as many as you 
would ever need (or want) to use. For others of you, a measly three worksheets might seldom, if ever, be sufficient 
for the workbooks you create. (For example, say your company operates in ten locations, or you routinely create 
budgets for 20 different departments or track expenses for 40 account representatives.) 

Excel makes it easy to insert additional worksheets in a workbook or remove those that you don't need. To insert a 
new worksheet in the workbook, follow these steps: 

1. Select the tab of the sheet where you want Excel to insert the new worksheet. 

2. Choose Insert-->Worksheet or choose Insert on the sheet tab's shortcut menu. 

If you choose the Insert-->Worksheet command, Excel inserts a new worksheet and gives its tab the next 
available number (like Sheet4). If you choose the Insert command on the sheet tab's shortcut menu, Excel 
opens the Insert dialog box where you can specify the type of sheet to insert (such as Worksheet, Chart, MS 
Excel 4.0 Macro, or MS Excel 5.0), and you need to proceed to Step 3. 

3. Make sure that the Worksheet icon on the General tab of the Insert dialog box is selected and then 
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click OK or press Enter. 

To insert a bunch of new worksheets in a row in the workbook, select a group with the same number of tabs as the 
number of new worksheets you want to add, starting with the tab where the new worksheets are to be inserted. 
Next, choose Insert-->Worksheet or choose Insert on the tab's shortcut menu. Finally, click OK in the Insert dialog 
box or press Enter. 

To delete a worksheet from the workbook, follow these steps: 

1. Click the tab of the worksheet you want to delete. 

2. Choose EditDelete Sheet or choose Delete on the tab's shortcut menu. 

Excel then displays a scary message in an alert box about how you're going to permanently delete the selected 
sheets. 

3. Go ahead and click the OK button or press Enter if you're really sure that you want to zap the entire 
sheet. 

 

Just keep in mind that this is one of those situations where Undo is powerless to put things right by restoring 
the deleted sheet to the workbook. 

To delete a bunch of worksheets from the workbook, select all the worksheets you want to delete and choose  
Edit-->Delete Sheet or choose Delete on the tab's shortcut menu. Then, if you're sure that none of the worksheets 
will be missed, click OK or press Enter when the alert dialog box appears. 

 

If you find that you constantly have to monkey around with the number of worksheets in a workbook, either by 
adding new worksheets or deleting a bunch, you may want to think about changing the default number of 
worksheets in a workbook. To change the magic number of three sheets to a more realistic number for your 
needs, choose  
Tools-->Options to open the Options dialog box, select the General tab, and enter a new number between 1 and 
255 in the Sheets in new workbook text box or select a new number with the spinner buttons before you click OK. 

 

 

  

 

 

 

Changing the Color of a Sheet Tab in Excel 2003  

Adapted From: Excel 2003 For Dummies  

In Excel 2003, you can assign colors to the different worksheet tabs. This feature enables you to color-code 
different worksheets. For example, you could assign red to the tabs of those worksheets that need immediate 
checking and blue to the tabs of those sheets that you've already checked. 

To assign a color to a worksheet tab, right-click the tab and choose Tab Color from its shortcut menu to open the 
Format Tab Color dialog box. Click the color that you want to assign to the selected sheet tab in the Format Tab 
Color dialog box, and then click OK. When the Format Tab Color dialog box disappears, the name of the active 
sheet tab appears underlined in the color you just selected. When you make another sheet tab active, the entire 
tab takes on the assigned color (and the text of the tab name changes to white if the selected color is sufficiently 
dark that black lettering is impossible to read). 

To remove a color from a tab, open the Format Tab Color dialog box from the tab's shortcut menu and then choose 
the No Color selection at the very top before clicking OK. 

 

 

  

 

 

 

Formatting the X-Axis or Y-Axis of a Chart in Excel 2002  

Adapted From: Excel 2002 For Dummies  
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When charting a bunch of values, Excel isn't too careful how it formats the values that appear on the y-axis (or the 
x-axis when using some chart types, such as the 3-D Column chart or the XY Scatter chart). If you're not happy 
with the way the values appear on either the x-axis or  
y-axis, you can change the formatting as follows: 

1. Double-click the x-axis or y-axis in the chart or click the axis and then choose Format-->Selected Axis 
on the menu bar (or press Ctrl+1). 

Excel opens the Format Axis dialog box containing the following tabs: Patterns, Scale, Font, Number, and 
Alignment. 

2. To change the appearance of the tick marks along the axis, change the options on the Patterns tab 
(which is automatically selected when you first open the Format Axis dialog box) however you desire. 

3. To change the scale of the selected axis, click the Scale tab and change the Scale options the way 
you want. 

4. To change the font of the labels that appear at the tick marks on the selected axis, click the Font tab 
and change the Font options however you desire. 

5. To change the formatting of the values that appear at the tick marks on the selected axis, select the 
Number tab; then, choose type of format in the Category list box followed by the appropriate options 
associated with that category.  

For example, to select the Currency format with no decimal places, you select Currency in the Category list box 
and then enter 0 in the Decimal Places text box or select 0 with the spinner buttons. 

6. To change the formatting of the orientation of the labels that appear at the tick marks on the selected 
axis, select the Alignment tab. Then indicate the new orientation by clicking it in the sample Text box or 
by entering the number of degrees (between 90 and  
–90) in the Degrees text box (or by selecting this number with the spinner buttons). 

7. Click OK or press Enter to close the Format Axis dialog box. 

As soon as you close the Format Axis dialog box, Excel redraws the axis of the chart according to the new settings. 
For example, if you choose a new number format for a chart, Excel immediately formats all the numbers that 
appear along the selected axis using that format. 

 

  

 
 

Ordering Up Organizational Charts in Excel 2002  

Adapted From: Excel 2002 For Dummies  

In Excel 2002, the Drawing toolbar contains an Insert Diagram or Organization Chart button that you can use to quickly 
and easily add organization charts to your worksheets. Simply click the Insert Diagram or Organization Chart button to 
display the Diagram Gallery dialog box (shown in Figure 1). Select the type of chart to draw by double-clicking its image 
or clicking the image and then clicking OK. 
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Figure 1: Select an organization chart from the Diagram Gallery. 

After Excel inserts the basic structure of the org chart into your worksheet, you can replace the stock text with your own 
by clicking the Click to Add Text button (what else would Microsoft call it?) and typing in the name or title of the person 
or place that inhabits each level of the chart (as shown in Figure 2). 

http://suratiundhiyu.wordpress.com/


http://suratiundhiyu.wordpress.com/ Page 17 

 

 

Figure 2: Format text you add to your org charts. 

To insert an additional shape at the same manager level in the chart, choose the Coworker option on the Insert Shape 
pop-up menu. To insert a shape for a subordinate managerial level directly below the one that's currently selected, 
choose the Subordinate option on this pop-up menu. To insert a shape for a subordinate managerial level that is 
indirectly connected to the shape that's currently selected, choose Assistant on the pop-up menu. 

 

To enhance the look of your org chart, click the AutoFormat button on the Organization Chart toolbar and then select 
the diagram style you want to apply to the entire org chart from the Organization Chart Style Gallery dialog box. To 
have Excel size the text you add to the size of the shapes in the chart, choose the Fit Organization Chart to Contents 
option on the Layout pop-up menu. To increase the size of the shapes and the overall size of the chart to fit the text 
that you enter in the chart, choose the Expand Organization Chart option on the Layout pop-up menu instead. 

 

 

  

 

 

Taming the Excel 2002 Task Panes  

Adapted From: Excel 2002 For Dummies  

When you first launch Excel with a blank workbook, Excel 2002 automatically opens the New Workbook task pane 
to the immediate right of the workbook. You can use this task pane to edit recently opened workbooks or to create 
other new workbooks. Along with the New Workbook task pane, Excel 2002 supports two other standard task 
panes: a Clipboard and a Search task pane. 

You use the Clipboard task pane to view and paste any data that you cut or copy to the Windows clipboard — that 
is, from any Office XP program, not just from your Excel workbook. Use the Search task pane to locate files that 
you create (with any Office XP program, not just Excel workbooks) or store on your computer's hard drive (such as 
e-mail messages). You can also use this task pane to find particular values and text that you've entered in the 
current workbook. 
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In addition to these three standard task panes that are available whenever you work in Excel, you may also 
encounter specialized task panes that appear only when you perform a particular task. For example, if you use the 
Insert-->Picture-->Clip Art command to insert a piece of Office XP Clip Art, an Insert Clip Art task pane appears. 
You use this Task pane to search for the particular type of images that you want to insert, as well as to open the 
new Clip Art Media Gallery where you view any art images by category that you may want to use. 

You can turn off the display of any Excel Task pane by clicking its Close box located in the upper-right corner of its 
window. If you close the Task pane when working in Excel (so as to maximize the number of cells displayed on 
your computer screen), it remains closed until you choose the View-->Task Pane or View-->Toolbars-->Task Pane 
command on the Excel menu bar. 

When the Task pane is displayed, you can select the type of Task pane that you want open by clicking the drop-
down button on to the immediate left of the Task pane Close box and then selecting the type of pane to use. 
Choose from New from Existing Workbook, Clipboard, and Search. After selecting a new type of Task pane, you 
can scroll between the different Task pane choices by clicking the Previous and Next buttons (marked by a left and 
right arrow icon, respectively). 

 

If you decide that you don't want the New Workbook Task pane to automatically display each time that you start up 
Excel with a blank workbook, you can turn off this feature by removing (deselecting) the check mark in the Show at 
Startup check box at the very bottom of this task pane. You can also do the same thing by removing the check 
mark from the Startup Task pane check box that is located on the View tab of the Options dialog box and opened 
by choosing Tools-->Options from the Excel menu bar. 

 

 

 

Making Plotted Data Charts Easier to Decipher in Excel  

Adapted From: Excel Timesaving Techniques For Dummies  

The plot area of a new Excel chart often needs modification. What you can do to make this area easier to 
understand depends heavily on the type of chart you're working. Some chart types such as those in the Pie chart 
category allow for very little improvement to their plot areas, whereas others such as Clustered Column and 
Clustered Bar charts allow for a great deal. 

For charts that use both an X-axis and a Y-axis, sometimes the easiest thing you can do to improve the legibility of 
the chart is simply to add minor gridlines. Depending upon the type of chart, these extra lines can guide the eye 
from the tick marks displaying the closest values on the Y-axis to the actual data points in the chart. 

To add (or remove) gridlines from a chart that uses them, follow these steps: 

1. Choose Chart --> Chart Options to open the Chart Options dialog box. 

You need to select the chart to add the Chart menu to the menu bar when working with an embedded chart. 

2. On the Gridlines tab, select (or deselect) the Major Gridlines and/or Minor Gridlines check boxes for 
the appropriate axis. 

3. When you finish, click OK. 

Figure 1 shows a Clustered Column chart with minor gridlines added to the Value (Y) axis and major gridlines on 
the Category (X) axis. Note how well the major vertical gridlines for the X-axis clearly delineate the clusters with 
each data series. 
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Figure 1: Clustered Column chart with major X-axis and minor Y-axis gridlines. 

When you're dealing with a chart where displaying the underlying numerical data visually represented in the plot 
area is important to its understanding, you have a couple of choices: 

 Display a data table that shows all the graphed numbers in a standard row-and-column table format appearing 
immediately beneath the chart area. To add a data table to a chart, just click the Data Table button on the Chart 
toolbar. 

 Add data labels that display the numbers right next to each data point in the graph. To display the values as 
data labels, select the Data Labels tab of the Chart Options dialog box (Chart --> Chart Options) and then select 
the Value check box option. 

 

When Excel adds a data table or displays values as data labels in a chart, it formats these values exactly as they 
are in the worksheet itself. To apply a more compact number format in these chart elements, you must assign the 
new truncated number format to the cells in the worksheet that contain the actually graphed numbers. 

Figure 2 shows the final version of the embedded Clustered Column chart. Here, along with the major X-axis 
gridlines and the minor Y-axis gridlines, you see that the chart's legend is now gone and a data table appears. 
Because the data table automatically includes the legend's color keys as part of its row headings, there is no longer 
any need to give up any precious chart real estate to the legend. The final version of this embedded chart 
maintains a balance between the graphic and textual elements while at the same time is easy to read and to 
interpret. 
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Figure 2: Final Clustered Column chart after adding a data table and removing the legend. 

 

  

 

 
Checking for Specific Worksheet Errors 

 

Excel comes with a feature that alerts you to specific types of errors or potential errors in your worksheet. Excel can flag 

the following types of errors.  

 Formulas that evaluate to error values (for example, #DIV/0!, #VALUE!, #N/A, and so on).  

 Text dates (that is, dates that you format as text or precede with an apostrophe) that you enter with two-digit 

years.  

 Numbers that you store as text (that is, numbers that you format as text or precede with an apostrophe).  

 Inconsistent formulas in a region (that is, different from formulas in surrounding cells).  

 Formulas that omit cells in a region (for example, a formula that sums a range but omits the last cell or cells in the 

range).  

 Unlocked cells containing formulas if the worksheet is protected.  

 Formulas containing references to cells that are empty.  

Remember: Use Excel's suggestions to serve as a guide only to alert you of potential errors on your worksheet because 

some of the data that you enter intentionally Excel may flag as errors.  

Excel's error-alert feature isn't foolproof. You should use it in conjunction with other techniques to make the most of it.  

Start crunching numbers today with Excel 2002 For Dummies Quick Reference, by Colin Banfield and John Walkenbach.  

 

Comparing Excel 2003 Worksheets Side by Side 

http://suratiundhiyu.wordpress.com/
http://xads.zedo.com/ads2/c?a=74341;g=0;c=394000001;i=0;x=3840;n=394;s=1;k=http://www.dummies.com/WileyCDA/DummiesTitle/productCd-0764508296.html


http://suratiundhiyu.wordpress.com/ Page 21 

 

 

You can use the new Compare Side by Side With command on the Window menu to quickly and easily do a side by side comparison of any 
two Excel 2003 worksheet windows that you have open. When you choose Window --> Compare Side by Side With from the menu bar after 
opening two windows, Excel automatically tiles them horizontally (as though you had selected the Horizontal option in the Arrange Windows 
dialog box), while at the same time displaying the Compare Side by Side toolbar (shown in Figure 1). 

 
Figure 1: Comparing two worksheet windows side by side. 

If you have more than two windows open at the time you choose Window --> Compare Side by Side With, Excel opens the Compare Side by 
Side dialog box where you click the name of the window that you want to compare with the one that's active at the time you choose the 
command. As soon as you click OK in the Compare Side by Side dialog box, Excel horizontally tiles the active window above the one you 
just selected. 

The Compare Side by Side toolbar contains the follow three buttons: 

 Synchronous Scrolling: When you activate this button by first clicking it, any scrolling that you do in the worksheet in the active window 
is mirrored and synchronized in the worksheet in the inactive window beneath it. To be able to scroll the worksheet in the active window 
independently of the inactive window, click the Synchronous Scrolling button a second time to deactivate it. 

 Reset Window Position: Click this button after manually resizing the active window (by dragging its size box) to restore the two windows 
to their previous side-by-side arrangement 

 Break Side by Side: When you click this button, Excel returns the windows to whatever display arrangement you selected before 
choosing the Window --> Compare Side by Side With command. If you haven't previously selected a display option in the Arrange 
Windows dialog box, Excel just displays the active window full size. 

 

Deciphering the Excel 2003 Custom Number Formats 
 

http://suratiundhiyu.wordpress.com/


http://suratiundhiyu.wordpress.com/ Page 22 

 

For the most part, the different number categories in the Category list box and their types are pretty easy — if not a breeze — to 
comprehend. For most people, that self-assured feeling goes right out the window as soon as they click the Custom category and get a load 
of its accompanying Type list box, shown in Figure 1. It starts off with the nice word General, then 0, then 0.00, and after that, all hell breaks 
loose! Codes with 0s and #s (and other junk) start to appear, and it only goes downhill from there. 

 
 
Figure 1: Selecting Custom in the Category list box of the Number tab. 

As you move down the list, the longer codes are divided into sections separated by semicolons and enclosed within square brackets. 
Although at first glance these codes appear as so much gibberish, you'll actually find that they're quite understandable (well, would you 
believe useful, then?). 

And these codes can be useful, especially after you understand them. You can use them to create number formats of your own design. The 
basic keys to understanding number format codes are as follows: 

 Excel number formats use a combination of 0, ?, and # symbols with such punctuation as dollar signs, percent signs, and commas to 
stand for the formatted digits in the numbers that you format. 

 The 0 is used to indicate how many decimal places (if any) are allowed in the format. The format code 0.00 indicates that two decimal 
places are used in the number. The format code 0 alone indicates that no decimal places appear (the display of all values is rounded up 
to whole numbers). 

 The ? is used like the 0, except that it inserts spaces at the end as needed to make sure that values line up on the decimal point. For 
example, by selecting the number format 0.??, such values as 10.5 and 24.71 line up with each other in their cells because Excel adds an 
extra space after the 5 to push it over to the left so that it's in line with the 7 of 71. If you used the number format 0.00 instead, these two 
values would not line up on the decimal point when they are right-aligned in their cells. 

 The # symbol is used with a comma to indicate that you want thousands, hundred thousands, millions, zillions, and so on in your 
numbers, with each group of three digits to be separated with a comma. 

 The $ (dollar sign) symbol is added to the beginning of a number format if you want dollar signs to appear at the beginning of every 
formatted number. 

 The % (percent sign) symbol is added to the end of the number format if you want Excel to actually transform the value into a percentage 
(multiplying it by 100 and adding a percent sign). 
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Number formats can specify one format for positive values, another for negative values, a third for zero values, and even a fourth format for 
text in the cells. In such complex formats, the format codes for positive values come first, followed by the codes for negative values, and a 
semicolon separates each group of codes. Any format codes for how to handle zeros and text in a cell come third and fourth, respectively, in 
the number format, again separated by semicolons. If the number format doesn't specify special formatting for negative or zero values, these 
values are automatically formatted like positive values. If the number format doesn't specify what to do with text, text is formatted according 
to Excel's default values. For example, look at the following number format: 

#,##0_);(#,##0) 

This particular number format specifies how to format positive values (the codes in front of the semicolon) and negative values (the codes 
after the semicolon). Because no further groups of codes exist, zeros are formatted like positive values, and no special formatting is applied 
to text. 

If a number format puts negative values inside parentheses, the positive number format portion often pads the positive values with a space 
that is the same width as a right parenthesis. To indicate this, you add an underscore (by pressing Shift and the hyphen key) followed 
immediately by a closed parenthesis symbol. By padding positive numbers with a space equivalent to a right parenthesis, you ensure that 
digits of both positive and negative values line up in a column of cells. 

You can assign different colors to a number format. For example, you can create a format that displays the values in green (the color of 
money!) by adding the code [GREEN] at the beginning of the format. A more common use of color is to display just the negative numbers in 
red (ergo the saying "in the red") by inserting the code [RED] right after the semicolon separating the format for positive numbers from the 
one for negative numbers. Color codes include [BLACK], [BLUE], [CYAN], [GREEN], [MAGENTA], [RED], [WHITE], [YELLOW], and 
[COLOR n] where n is the number of the Standard Color between 1 and 16 that you want to select from the Excel color palette. (To see the 
palette and its colors, choose Tools --> Options and then select the Color tab. When assigning a number to a color, count from left to right 
across each row: 1 to 8 across the top row and 9 to 16 across the second row, and so on.) 

Date number formats use a series of abbreviations for month, day, and year that are separated by characters, such as a dash (—) or a slash 
(/). The code m inserts the month as a number: mmm inserts the month as three-letter abbreviation, such as Apr or Oct, and mmmm spells 
out the entire month, such as April or October. The code d inserts the date as a number: dd inserts the date as a number with a leading 
zero, such as 04 or 07; ddd inserts the date as a three-letter abbreviation of the day of the week, such as Mon or Tue; and dddd inserts the 
full name of the day of the week, such as Monday or Tuesday. The code yy inserts the last two digits of the year, such as 05 or 07; yyyy 
inserts all four digits of the year, such as 2005, 2007, and so on. 

Time number formats use a series of abbreviations for the hour, minutes, and seconds. The code h inserts the number of the hour; hh 
inserts the number of the hour with leading zeros, such as 02 or 06. The code m inserts the minutes; the code mm inserts the minutes with 
leading zeros, such as 01 or 09. The code s inserts the number of seconds; ss inserts the seconds with leading zeros, such as 03 or 08. Add 
AM/PM or am/pm to have Excel tell time on a 12-hour clock, and add either AM (or am) or PM (or pm) to the time number depending upon 
whether the date is before or after noon. Without these AM/PM codes, Excel displays the time number on a 24-hour clock, just like the 
military does. (For example, 2:00 PM on a 12-hour clock is expressed as 1400 on a 24-hour clock.) 

So that's all you really need to know about making some sense of all those strange format codes that you see when you select the Custom 
category on the Number tab of the Format Cells dialog box. 

 

Password-Protecting an Excel 2003 File 
 

By password-protecting your Excel workbook, you can prevent unauthorized users from opening and/or editing the workbook. You set a 
password for opening the workbook file when you're dealing with a spreadsheet whose data is of a sufficiently sensitive nature that only a 
certain group of people in the company should have access to it (such as spreadsheets dealing with personal information and salaries). Of 
course, after you set the password required in order to open the workbook, you must supply this password to those people who need access 
in order to make it possible for them to open the workbook file. 

You set a password for modifying the workbook when you're dealing with a spreadsheet whose data needs to be viewed and printed by 
different users, none of whom are authorized to make changes to any of the entries. For example, you might assign a password for 
modifying to a workbook before distributing it companywide, after the workbook's been through a complete editing and review cycle and all 
the suggested changes have been merged. 

If you're dealing with a spreadsheet whose data is of a sensitive nature and should not be modified by anyone who's authorized to open it, 
you need to set both a password for opening and a password for modifying the workbook file. You assign either one or both of these types of 
passwords to a workbook file at the time you save it with the File --> Save As command on the Excel menu bar. 

When you choose this command (or choose the File --> Save command for a new file that's never been saved before), Excel opens the 
Save As dialog box. You can then set the password to open and/or the password to modify the file by taking these steps: 
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1. Click the Tools pop-up button in the Save As dialog box and then click General Options on the pop-up menu. 

Doing this opens the Save Options dialog box where you can enter a password to open and/or a password to modify. When entering a 
password, it can be up to 255 characters long and consist of a combination of letters and numbers with spaces. When using letters, 
however, keep in mind that passwords are case-sensitive, so opensesame and OpenSesame are not the same password because of the 
different use of upper- and lowercase letters. 

 

When entering a password, make sure that you don't enter something that you can't easily reproduce or, for heaven's sake, that you 
can't remember. You must be able to immediately reproduce the password in order to assign it, and you must be able to reproduce it 
later if you ever want to be able to open or change the darned workbook ever again. 

2. (Optional) If you want to assign a password to open the file, type the password (up to 255 characters maximum) in Password 
to Open text box. 

As you type the password, Excel masks the actual characters you type by rendering them as asterisks (*) in the text box. 

By default, Excel assigns an Office 97/2000 Compatible type encryption when you assign a password to open the file. You can use the 
Advanced button to assign another type of encryption for password-protecting the opening of the file. You should not, however, fool with 
these options unless you know what you're doing or have been instructed to use another type by someone in your IT department. 

If you decide to assign a password for opening and modifying the workbook at the same time, proceed to Step 3. Otherwise, skip to Step 
4. 

When entering the password for modifying the workbook, you want to assign a password that's different from the one you just assigned 
for opening the file (if you did assign a password for opening the file in this step). 

3. (Optional) If you want to assign a password for modifying the workbook, click the Password to Modify text box and then type 
the password for modifying the workbook there. 

Before you can assign a password to open the file and/or to modify the file, you must confirm the password by reproducing it in a Confirm 
Password dialog box exactly as you originally entered it. 

4. Click the OK button. 

Doing this closes the Save Options dialog box and opens a Confirm Password dialog box, where you need to exactly reproduce the 
password. If you just entered a password in the Password to Open text box, you need to reenter this password in the Confirm Password 
dialog box. If you just entered a password in the Password to Modify text box, you need only to reproduce this password in the Confirm 
Password dialog box. However, if you entered a password in both the Password to Open text box and the Password to Modify text box, 
you must reproduce those passwords. In the first Confirm Password dialog box, enter the password you entered in the Password to Open 
text box. Immediately after you click OK in the first Confirm Password dialog box, the second Confirm Password dialog box appears, 
where you reproduce the password you entered in the Password to Modify text box. 

5. Type the password exactly as you entered it in the Password to Open text box (or Password to Modify text box, if you didn't 
use the Password to Open text box), and then click OK. 

If your password does not match exactly (in both characters and case) the one you originally entered, Excel displays an alert dialog box, 
indicating that the confirmation password is not identical. When you click OK in this alert dialog box, Excel returns you to the original Save 
Options dialog box where you can do one of two things: 

• Reenter the password in the original text box. 

• Click the OK button to redisplay the Confirm Password dialog box, where you can try again to reproduce the original. (Make sure that 
you've not engaged the Caps Lock key by accident.) 

If you assigned both a password to open the workbook and one to modify it, Excel displays a second Confirm Password dialog box as 
soon as you click OK in the first one and successfully reproduce the password to open the file. You then repeat Step 5, this time, exactly 
reproducing the password to modify the workbook before you click OK. 

When you finish confirming the original password(s), you are ready to save the workbook in the Save As dialog box. 
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6. (Optional) If you want to save the password-protected version under a new filename or in a different folder, edit the name in 
the File Name text box and then select the new folder on the Save In drop-down list. 

7. Click the Save button to save the workbook with the password to open and/or password to modify. 

As soon as you do this, Excel saves the file if this is the first time you've saved it. If not, the program displays an alert dialog box 
indicating that the file you're saving already exists and asking you if you want to replace the existing file. 

8. Click the Yes button if the alert dialog box that asks if you want to replace the existing file appears. 

 
 
Get to Know AutoSum 
 

The AutoSum tool on the Standard toolbar is worth its weight in gold -- it does more than just enter the SUM function. It 

also selects the most likely range of cells in the current column or row that you want totaled and automatically enters them 

as the function's argument. And nine times out of ten, Excel selects (by highlighting) the correct cell range to be totaled. 

For that tenth case, you can manually correct the range by simply dragging the cell pointer through the block of cells that 

need to be summed.  

Position the cell pointer in the cell where the sum is to appear, and click the AutoSum tool (the button looks like a stylized 

capital letter E). Excel inserts the SUM function (equal sign and all) onto the Formula bar; places a marquee (the moving 

dotted line) around the cells it thinks you want to add; and uses that cell range as the argument of the SUM function.  

 
Calibrating Columns 
 

For those times when Excel doesn't automatically adjust the width of your columns to your complete satisfaction, the 

program makes your changing the column widths a breeze. The easiest way to adjust a column is to do a best-fit, using 

the AutoFit feature. With this method, Excel automatically determines how much to widen or narrow the column to fit the 

longest entry currently in the column.  

Here's how to use AutoFit to get the best-fit for a column:  

1. Position the mouse pointer on the right border of the gray frame with the column letter at the top of the 

worksheet.  

The mouse pointer changes to a double-headed arrow pointing left and right.  

2. Double-click the mouse button.  

Excel widens or narrows the column width to suit the longest entry.  

You can apply a best-fit to more than one column at a time. Simply select all the columns that need adjusting (if the 

columns neighbor one another, drag through their column letters on the frame; if they don't, hold down the Ctrl key while 

you click the individual column letters). After you select the columns, double-click any of the right borders on the frame.  

http://suratiundhiyu.wordpress.com/


http://suratiundhiyu.wordpress.com/ Page 26 

 

Packed with expert tips and tricks, here's a friendly guide to walk you step-by-step through Excel fundamentals. Pick up a 

copy of Excel 2003 For Dummies, by Greg Harvey.  

 
Getting Out Your Scissors and Glue in Excel 2003 
 

You can use the old standby Cut, Copy, and Paste commands to move or copy information in an Excel 2003 worksheet. These commands 
use the Clipboard as a kind of electronic halfway house where the information you cut or copy remains until you decide to paste it 
somewhere. Because of this Clipboard arrangement, you can use these commands to move or copy information to any other worksheet 
open in Excel or even to other programs running in Windows (such as a Word document). 

To move a cell selection with Cut and Paste, follow these steps: 

1. Select the cells you want to move. 

2. Click the Cut button on the Standard toolbar (the button with the scissors icon). 

Or, if you prefer, you can choose Cut from the cell shortcut menu or Edit --> Cut from the menu bar. 

You can cut out all of this button-and-menu stuff and just press Ctrl+X. Whenever you choose the Cut command in Excel, the program 
surrounds the cell selection with a marquee (a dotted line that travels around the cells' outline) and displays the following message on the 
status bar: 

Select destination and press ENTER or choose Paste 

3. Move the cell pointer to, or select, the cell in the upper-left corner of the new range to which you want the information moved. 

4. Press Enter to complete the move operation. 

Or, if you're feeling really ambitious, click the Paste button on the Standard toolbar, or choose Paste from the cell shortcut menu, or 
choose Edit --> Paste from the menu bar, or press Ctrl+V. (Do you think that there are enough pasting alternatives in Excel?) 

Notice that when you indicate the destination range, you don't have to select a range of blank cells that matches the shape and size of the 
cell selection you're moving. Excel only needs to know the location of the cell in the upper-left corner of the destination range to figure out 
where to put the rest of the cells. 

Copying a cell selection with the Copy and Paste commands follows an identical procedure to the one you use with the Cut and Paste 
commands. After selecting the range to copy, you have even more choices about how to get the information into the Clipboard. Instead of 
clicking the Copy button on the Standard toolbar or choosing Copy from the cell shortcut menu or Copy from the Edit menu, you can press 
Ctrl+C. 

Keeping pace with the Paste Options 

Right after you click the Paste button on the Standard toolbar or choose the Edit --> Paste command from the menu bar to paste cell entries 
that you copy (not cut) to the Clipboard, Excel displays a Paste Options button with its own drop-down button at the end of the pasted range. 
You can use the options available when you click the drop-down button to modify the paste operation in the following ways: 

 Keep Source Formatting: When you select this option, Excel copies the formatting from the original cells and pastes this into the 
destination cells (along with the copied entries). 

 Match Destination Formatting: When you select this option, Excel formats the copied entries according to the formatting assigned to 
the destination cell range. 

 Values Only: When you select this option, Excel copies only the calculated results from any formulas in the source range into the 
destination range. This means that the destination range will consist of entirely of labels and values regardless of how many formulas 
exist in the source range. 
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 Values and Number Formatting: When you select this option, Excel copies the calculated results of any formulas along with the number 
formatting assigned to both the values and formulas in the source cell range to the destination range. This means that labels copied from 
the source range take on the formatting of the destination range, while the values retain the number format given to them in the source 
range. 

 Values and Source Formatting: When you select this option, Excel copies the calculated results of any formulas along with all the 
formatting assigned to the labels, values, and formulas in the source cell range to the destination range. This means that all the labels 
and values in the destination range appear formatted just like the source range even though all the original formulas are lost and only the 
calculated values are retained. 

 Keep Source Column Widths: When you select this option, Excel makes the width of the columns in the destination range the same as 
those in the source range when it copies their cell entries. 

 Formatting Only: When you select this option, Excel copies only the formatting (and not the entries) from the source cell range to the 
destination range. 

 Link Cells: When you select his option, Excel creates linking formulas in the destination range so that any changes that you make to the 
entries in cells in the source range are immediately brought forward and reflected in the corresponding cells of the destination range. 

So what's so special about Paste Special? 

Normally, unless you fool around with the Paste Options, Excel copies all the information in the range of cells you selected: formatting, as 
well the formulas, text, and other values you enter. If you want, use the Paste Special command to specify that only the entries be copied 
(without the formatting) or that just the formatting be copied (without the entries). You can also use this command to have Excel copy only 
values in a cell selection, which means that Excel copies all text entries and values entered in a cell selection but does not include formulas 
or formatting (just like selecting the Values Only Paste option described in the previous section). When you paste values, Excel discards all 
formulas in the cell selection and retains only the calculated values — these values appear in the new cell range just as though you had 
entered them manually. 

To paste particular parts of a cell selection while discarding others, choose Edit --> Paste Special from the menu bar. When you choose 
Paste Special over the regular Paste command, Excel displays the Paste Special dialog box. Here you can specify which parts of the current 
cell selection to use by selecting the appropriate Paste Special radio button or check box as follows: 

 All to paste all the stuff in the cell selection (formulas, formatting, you name it). 

 Formulas to paste all the text, numbers, and formulas in the current cell selection without their formatting. 

 Values to convert formulas in the current cell selection to their calculated values. 

 Formats to paste only the formatting from the current cell selection, leaving the cell entries in the dust. 

 Comments to paste only the notes that you attach to their cells (kinda like electronic self-stick notes). 

 Validation to paste only the data validation rules into the cell range that you set up with the Data --> Validation command (which enables 
you to set what value or range of values is allowed in a particular cell or cell range). 

 All Except Borders to paste all the stuff in the cell selection without copying any borders you use there. 

 Column Widths to apply the column widths of the cells copied to the Clipboard to the columns where the cells are pasted. 

 Formulas and Number Formats to include the number formats assigned to the pasted values and formulas. 

 Values and Number Formats to convert formulas to their calculated values and include the number formats you assign to all the pasted 
values. 

 None to have Excel perform no operation between the data entries you cut or copy to the Clipboard and the data entries in the cell range 
where you paste. 

 Add to add the data you cut or copy to the Clipboard and the data entries in the cell range where you paste. 
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 Subtract to subtract the data you cut or copy to the Clipboard from the data entries in the cell range where you paste. 

 Multiply to multiply the data you cut or copy to the Clipboard by the data entries in the cell range where you paste. 

 Divide to divide the data you cut or copy to the Clipboard by the data entries in the cell range where you paste. 

 Skip Blanks check box when you want Excel to paste everywhere except for any empty cells in the incoming range. In other words, a 
blank cell cannot overwrite your current cell entries. 

 Transpose check box when you want Excel to change the orientation of the pasted entries. For example, if the original cells' entries run 
down the rows of a single column of the worksheet, the transposed pasted entries will run across the columns of a single row. 

 Paste Link button when you're copying cell entries and you want to establish a link between copies you're pasting and the original 
entries. That way, changes to the original cells automatically update in the pasted copies. 

 

You can alternatively select the Formulas, Values, No Borders, Transpose, and Paste Link paste options directly from the pop-up menu 
attached to the Paste button on the Standard toolbar without having to open the Paste Special dialog box. Note: The No Borders option 
(from the Paste button of the Standard toolbar) is the same as the All Except Borders option from the Paste Special dialog box. Simply click 
the drop-down button attached to the Paste button and select the desired option from its pop-up menu. You can also open the Paste 
Special dialog box from this pop-up menu by selecting the Paste Special item at the very bottom of the menu. 

 
 
The Function of Formulas 
 

A formula is a special type of cell entry that returns a result: When you enter a formula into a cell, the cell displays the 

result of the formula. The formula itself appears in the formula bar (which is just below the toolbars at the top of the Excel 

window) when the cell is activated.  

A formula begins with an equal sign (=) and can consist of any of the following elements:  

 Operators such as + (for addition) and * (for multiplication)  

 Cell references, including addresses such as B4 or C12, as well as named cells and ranges  

 Values and text  

 Worksheet functions (such as SUM)  

You can enter a formula into a cell in three ways: manually (typing it in), by pointing to cell references, or with the 

assistance of the formula palette.  

Packed with expert tips and tricks, here's a friendly guide to walk you step-by-step through Excel fundamentals. Pick up a 

copy of Excel 2000 For Windows For Dummies Quick Reference, by John Walkenbach.  

 
Opening Files with a Twist in Excel 2003 
 

Before you can do any damage — er, make changes — in an Excel 2003 workbook, you have to first open up the darn thing. To open a 
workbook, just click the Open button on the Standard toolbar (normally the one second from the left, with the picture of a file folder opening 
up), or you can choose File-->Open from the menu bar, or use the keyboard shortcuts Ctrl+O or Ctrl+F12. 

However you open it, Excel displays the open dialog box similar to the one in Figure 1. Then you select the workbook file you want to work 
on from the list box in the middle of the Open dialog box. 
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Figure 1: Use the Open dialog to find and open a workbook for editing. 

The pop-up menu attached to the Open button in the Open dialog enables you to open the selected workbook file(s) in special ways. These 
ways include the following: 

 Open Read Only: This command opens the files you select in the Open dialog box's list box in a read-only state, which means that you 
can look but you can't touch (actually, you can touch, you just can't save your changes). To save changes in a read-only file, you must 
use the File-->Save As command from the Excel menu bar and give the workbook file a new filename.  

 Open as Copy: This command opens a copy of the files you select in the Open dialog box. Use this method of file-opening as a safety 
net: If you mess up the copies, you always have the originals to fall back on. 

 Open in Browser: This command opens workbook files you save as Web pages in your favorite Web browser (which would normally be 
Microsoft Internet Explorer). Note that this command is not available unless the program identifies that the selected file or files were 
saved as Web pages rather than plain old Excel worksheet files. 

Open and Repair: This command attempts to repair corrupted workbook files before opening them in Excel. When you select this 
command, a dialog box appears giving you a choice between attempting to repair the corrupted file and opening the recovered version and 
extracting the data out of the corrupted file and placing it in a new workbook (which you can save with the File-->Save command). Click the 
Repair button to attempt to recover and open the file. Click the Extract Data button if you previously tried unsuccessfully to have Excel repair 
the file. 

 
Setting Up Document Recovery in Excel 2003 
 

Excel 2003 offers a document recovery feature that can help you in the event of a computer crash because of a power failure or some sort 
of operating system freeze or shutdown. The AutoRecover feature saves your workbooks on regular intervals. In the event of a computer 
crash, Excel displays a Document Recovery task pane the next time you start Excel after rebooting the computer. 
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When you first start using Excel 2003, the AutoRecover feature is set to automatically save changes to your workbook (provided that the file 
has already been saved) every ten minutes. You can shorten or lengthen this interval as you see fit. Choose Tools-->Options, and then click 
the Save tab. Use the spinner buttons or enter a new automatic save interval into the text box marked Save AutoRecover Info Every 10 
Minutes before clicking OK.  

The Document Recovery task pane shows the available versions of the workbook files that were open at the time of the computer crash. It 
identifies the original version of the workbook file and when it was saved along with the recovered version of the file and when it was saved. 
To open the recovered version of a workbook (to see how much of the work it contains that was unsaved at the time of the crash), position 
the mouse pointer over the AutoRecover version. Then click its drop-down menu button and click Open on its pop-up menu. After you open 
the recovered version, you can (if you choose) then save its changes by choosing File-->Save on the Excel menu bar. 

To save the recovered version of a workbook without bothering to first open it up, place your mouse over the recovered version, click its 
drop-down button, and choose the Save As option on the pop-up menu. To permanently abandon the recovered version (leaving you with 
only the data in the original version), click the Close button at the bottom of the Document Recovery task pane. When you click the Close 
button, an alert dialog box appears, giving you the chance to retain the recovered versions of the file for later viewing. To retain the files for 
later viewing, select the Yes (I want to view these files later) radio button before clicking OK. To retain only the original versions of the files 
shown in the task pane, select the No (Remove these files. I have saved the files I need) radio button instead. 

 

Note that the AutoRecover feature works only on Excel workbooks that you have saved at least one time. In other words, if you build a new 
workbook and don't bother to save and rename it prior to experiencing a computer crash, the AutoRecover feature will not bring back any 
part of it. For this reason, it is very, very important that you get into the habit of saving new workbooks with File-->Save very shortly after 
beginning work on one of its worksheets. Or, you can use the trusty keyboard shortcut Ctrl+S.  

 
 
Straightening Out the Sheets 

 
Spreadsheet programs like Excel 2002 refer to their electronic sheets as worksheets rather than spreadsheets. And, 
although it is perfectly acceptable (even preferable) to call one of its electronic sheets a worksheet, you never, never refer 
to Excel as a worksheet program -- it's always called a spreadsheet program. So you can think of Excel as a spreadsheet 
program that produces worksheets, but not as a worksheet program that produces spreadsheets. 
 

 
 

 
Creating Interactive Web Pages in Excel 
 

If you know that the users of your Web pages containing Excel data will be using Internet Explorer (Version 4.0 or later) to view them, you 
can make it possible for them to manipulate the data and make modest modifications to the worksheet data when viewing the pages in their 
Web browser. All you need to do to make this happen is to select the Add Interactivity check box in the Save As dialog box at the time you 
save the worksheet as a Web page. 

The types of manipulations and changes that users can make to the spreadsheet data of an interactive Web page in Internet Explorer 
depend upon the type of data that the page contains: 

 Worksheet data tables: Users can edit the cell entries and have the table's formulas updated either automatically or manually as well as 
modify the formatting of the cells in the table. 

 Data lists: Users can sort and filter the data in the list as well as modify field entries and make formatting changes to the list. 

 Pivot tables: Users can pivot the fields in a table as well as add new fields. They can also refresh the table data from the external data 
source (assuming that this source is accessible from the Web page), show details for any of the summarized data in the table, add 
calculated fields to the table, and page through the summaries by using different items in the Page Fields. 

 Charts: Users can edit supporting data (shown beneath the chart as an attached data table) and have the chart automatically updated on 
the page. 
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Figure 1 shows you how a typical interactive data table appears on a new Web page after opening it in Internet Explorer 6. Notice that the 
interactive table is self-contained with a toolbar at the top, a facsimile of the worksheet row and column header at the top, and vertical and 
horizontal scroll bars on the right and the bottom. Notice also that this table uses gridlines to demarcate the cells and sports a sheet tab at 
the bottom, just like a regular Excel workbook window. 

 
 
Figure 1: Interactive HTML worksheet opened in Internet Explorer. 

The Office Web Components add horizontal and vertical scroll bars to the interactive table because you have no way to resize the table. You 
must use the scroll buttons to bring new parts of the data table into view on the Web page. Likewise, the row and column headers are 
automatically displayed to give you a way to widen or narrow the columns and heighten or shorten the rows by dragging the appropriate 
border of a column letter or row number. 

Despite the obvious similarities to the Excel worksheet window, you can see some noticeable differences as well. The most significant 
difference is that the interactive spreadsheet table has no Formula bar or menu bar. 

Without a Formula bar, you can't tell which values in the table are calculated by formulas and which are input as constants. Also, the only 
way to edit a table cell is by double-clicking the cell and then editing the entry there (at which time, you can immediately tell whether it's a 
value or a formula that you're editing). 

Without a menu bar, you must pretty much rely upon the buttons on the toolbar to make changes that affect the entire table. The only other 
way to access commands that affect the table is by right-clicking one of the table cells to display its shortcut menu. The items on this 
shortcut menu duplicate the functions of the buttons at the top of the table, with the exception of the Insert and Delete items. These menu 
items both lead to the Rows and Columns submenu options that enable you to either insert or delete the columns or rows that are currently 
selected. 

To make up for the lack of a menu bar, the toolbar above the interactive worksheet contains a Commands and Options button. When you 
click this button, a Commands and Options dialog box with four tabs — Format, Formula, Sheet, and Workbook — appears, as shown in 
Figure 2. 
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Figure 2: Use the controls in this dialog box to make changes to an interactive worksheet table. 

These four tabs enable you to make the following types of changes: 

 The Format tab contains buttons and boxes for changing the font, size, alignment, border, and cell and text color of any cells that you've 
selected. 

 The Formula tab contains boxes that enable you to see the contents (very helpful when dealing with long formulas) and value of the 
active cell, along with all the range names defined in the table. You can even use its Define button to define a new range name for the 
current cell selection. 

 The Sheet tab is divided into Find What and Show/Hide sections. To find some text or values in the table, enter the search text in the 
Find What text box and then click the Find Next button (using the Match Case and Entire Cell Only check boxes if you need to refine the 
search). Select or deselect the Show/Hide check box options (Row Headers, Column Headers, Gridlines, and Display Right to Left) to 
control which interior table elements to display or hide. 

 The Workbook tab is divided into Calculation, Show/Hide, and Worksheets sections. Use the Manual and Automatic option buttons to 
switch from automatic recalculation (the default) to manual recalculation (in which case, you click the Calculate button to update table 
formulas). 

Use the Show/Hide check box options (Horizontal Scrollbar, Vertical Scrollbar, Sheet Selector, or Toolbar) to control which overall table 
elements to display or hide. (Note that you can't remove the scroll bars when the table is too large to show all the data in the table.) 
Use the Sheet Name text box to rename the table sheet that's selected in the list box below, the Insert button to insert a new sheet into 
the table, the Delete button to remove the current sheet, and the Hide button to hide the current sheet in the table. 
Use the Order buttons to move the current sheet ahead of (with the button with the upward-pointing arrow) or behind (with the button with 
the downward-pointing arrow) the other sheets in the table. 

 

Unfortunately, you can't save any of the changes that you make to an interactive Web page in Internet Explorer. The only way to save any 
formatting or editing changes you make to an interactive data table, data list, or pivot table is to export the page back to Excel as an XML 
(Extensible Markup Language) file and then save the changes there. 

 

 

Using Data Entry Forms  
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If you're entering data that is arranged in rows, you may find it helpful to use Excel's built-in data form for data entry. To 

enter data using a data entry form, follow these steps.  

1. If your data entry range does not have descriptive headings in the first row, enter some headings.  

You can always erase these headings later if you don't need them.  

2. Select any cell in the header row.  

3. Choose the Data, Form command.  

Excel asks if you want to use that row for headers (click OK). It then displays a dialog box with edit boxes and several 

buttons.  

4. Enter data into the edit boxes, using Tab to move between the boxes. When you complete entering the 

data for a row, click the New button. Click Close when finished.  

Excel dumps the data into the worksheet and clears the dialog box for the next row.  

 

Document Recovery to the Rescue 

Excel offers a document recovery feature that can help you in the event of a computer crash because of a power failure or some sort of 

operating system freeze or shutdown. The AutoRecover feature saves your workbooks on regular intervals. In the event of a computer 

crash, Excel displays a Document Recovery task pane the next time you start Excel after rebooting your computer.  

When you first start using Excel, the AutoRecover feature is set to automatically save changes to your workbook every ten minutes. 

You can shorten or lengthen this interval as you see fit. Choose Tools, Options, and then click the Save tab. Use the spinner buttons or 

enter a new automatic save interval into the text box marked "Save AutoRecover Info Every 10 Minutes" before clicking OK.  

Note that the AutoRecover feature works only on Excel workbooks that you have saved at least one time. In other words, if you build 

a new workbook and don't bother to save and rename it prior to experiencing a computer crash, the AutoRecover feature will not bring 

back any part of it. For this reason, it is very, very important that you get into the habit of saving new workbooks with File, Save very 

shortly after beginning work on one of its worksheets. Or, you can use the trusty keyboard shortcut Ctrl+S.  

From formatting to formulas, you can master the fundamentals of Excel with Excel 2003 For Dummies, by Greg Harvey.  

 

Some Sorta Order 

 

When you use the ascending sort order with a key field that contains many different kinds of entries, Excel places numbers (from 

smallest to largest) before text entries (in alphabetical order) . This is followed by any logical values (TRUE and FALSE), error 

values, and finally, blank cells. When you use the descending sort order, Excel arranges the different entries in reverse: Numbers are 

still first, arranged from largest to smallest; text entries go from Z to A; and the FALSE logical value precedes the TRUE logical 

value.  

Excel 2002 For Dummies, by Greg Harvey, not only shows you how to create worksheets and enter data, but also spells out ways to 

work with charts, databases, and hyperlinks.  

 

Adding a Legend to a Chart 

If you create your chart by using the Chart Wizard in Excel, you can include a legend. If you don't include a legend as you create the 

chart, you can add one later if you need one. To add a legend, follow these steps:  
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1. Activate the chart.  

2. Choose the Chart, Chart Options menu command. You can also right-click the border area of the chart and 

select Chart Options from the shortcut menu.  

Excel displays its Chart Options dialog box.  

3. Click the Legend tab.  

4. Select the Show Legend check box.  

5. Select a placement option for the legend by clicking the appropriate radio button: Bottom, Corner, Top, 

Right, or Left.  

The picture of the chart in the Legend tab displays how the legend appears on the chart for various placement options.  

6. Click OK.  

Start crunching numbers today with Excel 2002 For Dummies Quick Reference, by Colin Banfield and John Walkenbach. 

Audible Proofreading 

Excel comes with a text-to-speech feature that you can use as an aid in proofreading your spreadsheet data. This tool is 

useful for the sight-impaired but can also help if you're entering a lot of data manually -- for example, from a printed sheet. 

While you're entering the data into the range, you can look at the printed sheet while Excel confirms each entry audibly. 

Or, if you've already entered the data, you can check the printed sheet while Excel speaks out each entry.  

To use the text-to-speech feature, you need to display the Text to Speech toolbar. Follow these steps to display the 

toolbar and use its options:  

1. Choose the Tools, Speech, Show Text To Speech Toolbar menu command. (You can also choose the 

View, Toolbars, Text To Speech menu command.)  

Excel displays the Text To Speech Toolbar.  

2. If you want Excel to speak a range, select the range and click the By Rows or By Columns button to make 

Excel speak the cells across rows or down columns.  

3. Click the Speak Cells button for Excel to start speaking the cells.  

Click the Stop Speaking button for Excel to stop speaking the cells.  

4. If you want Excel to speak the cell every time that you enter data into a cell, click the Speak On Enter 

button.  

Click the button again to cancel the feature.  

Remember: Your PC must have the appropriate equipment for the text-to-speech feature to work. At minimum, you must 

have a sound card with speakers or a pair of headphones.  

The Speak On Enter tool persists across Excel sessions -- that is, if you enable it during one session and shut down 

Excel, it's still enabled the next time that you start Excel.  
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Stamping Out Errors with Text to Speech in Excel 2002 

Excel 2002 is unique in the Office XP suite in its support of the new Text to Speech feature, which enables you to have your computer read 
back any series of cell entries. This feature is perfect for when you need to check the accuracy of a bunch of numbers that you enter from a 
printed source. By using Text to Speech, you can check your printed source as the computer reads out loud the values and labels that 
you've actually entered. This new feature provides a real nifty way to catch and correct errors that may otherwise escape unnoticed. 

To use the Text to Speech feature to corroborate spreadsheet entries and catch those hard-to-spot errors, follow these steps: 

1. Select the cells in the worksheet that you want to convert to speech. 

2. Choose Tools-->Speech-->Show Text to Speech Toolbar from the Excel menu bar to display the Text to Speech toolbar 
(shown in Figure 1). 

 

Figure 1: Check your entries with the Text to Speech feature. 

3. Click the Speak Cells button in the Text to Speech toolbar (the first button, with the arrow pointing right) to have the 
computer begin reading back the entries in the selected cells. 

By default, the Text to Speech feature reads the contents of each cell in the current selection by first going across the rows and then 
down the columns. If you want Text to Speech to read down the columns and then across the rows, click the By Columns button on the 
toolbar (the fourth button, with the vertical arrow). 

4. To have the Text to Speech feature read back each cell entry as you press the Enter key (at which point the cell pointer 
moves down to the next cell in the selection), click the Speech on Enter button (the last button on the toolbar, with the curved 
arrow Enter symbol). 

After selecting this option, you need to press Enter each time that you want to hear an entry read back to you. 

5. To pause the Text to Speech feature when you're not using the Speech on Enter option (Step 4) and you locate a discrepancy 
between what you're reading and what you're hearing, click the Stop Speaking button (the second button on the toolbar, with 
the X). 

6. When you're finished checking all the entries in the current cell selection, click the Close box (the one with the X) in the 
upper-right corner of the Text to Speech toolbar to close it. 

Note that unlike when using Excel's Speech Recognition feature, the Text to Speech translation feature requires no prior training or special 
microphones. All that's required is a pair of speakers or headphones connected to your computer. 
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If you click the Speak on Enter button in the Text to Speech toolbar, the computer speaks each new cell entry that you make in a worksheet 
even after you close the Text to Speech toolbar. Just remember that you must complete the new cell entry by pressing the Enter key and 
not by some other method, such as clicking the Enter button on the formula bar or pressing the Down Arrow key in order to have the Text to 
Speech feature read what you just entered. 

By default, the Text to Speech feature selects the voice called LH Michelle, a somewhat mechanical but definitely female voice that 
suggests to me a female version of Stephen Hawking's computer-generated voice (perhaps that of his girlfriend?). Stephen Hawking, in 
case you don't know, is one of the most renowned theoretical physicists of our age (some regard him on par with Einstein). However, 
because of extreme physical disabilities, he's been forced to use a computer-generated voice in order to communicate his wonderful ideas 
about the origins of the universe. 

If you wish, you can change the voice of the Text to Speech translation feature from LH Michelle (female) to LH Michael (male, which is, in 
fact, the voice that Stephen Hawking uses). To do this, follow these steps: 

1. Choose Start-->Settings-->Control Panel from the taskbar. 

2. From Control Panel, double-click the Speech icon. 

The Speech Properties dialog box opens. 

3. From the Speech Properties dialog box, click the Text to Speech tab. 

Make your voice selection in this tab. Click the Voice Selection drop-down button and choose LH Michael from the pop-up menu. 

4. To slow down or speed up the speed of this voice, drag the Voice Speed slider left (to slow the voice down) or right (to speed 
it up). 

To check the speed of the voice you choose, click the Preview Voice button, located immediately above the Voice Speed slider. Excel 
plays you a sample voice at the speed you set. 

5. When you're happy with the voice speed, click OK to close the Speech Properties dialog box. 

6. Click the X in the upper-right corner of the Control Panel window to return to Excel. 

 

Fooling Around with Format Painter 

In Excel, when you feel the urge to format on the fly (so to speak), use the Format Painter on the Standard toolbar (the 

button that looks like a paintbrush right next to the Paste tool). This wonderful little tool enables you to take the formatting 

from a particular cell that you've fancied up and apply its formatting to other cells in the worksheet simply by selecting 

those cells.  

To use the Format Painter to copy a cell's formatting to other worksheet cells, just follow these easy steps:  

1. Format an example cell or cell range in your workbook, selecting whatever fonts, alignment, borders, 

patterns, and color you want it to have.  

2. With the cell pointer in one of the cells you just fancied up, click the Format Painter button in the 

Standard toolbar.  

The mouse pointer changes from the standard thick, white cross to a thick, white cross with an animated paintbrush by its 

side, and you see a marquee around the selected cell whose formatting is to be used by the Format Painter.  

3. Drag the white-cross-plus-animated-paintbrush pointer (the Format Painter pointer, for short) through all 

of the cells you want to format in the same manner as the example cell you first selected.  
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As soon as you release the mouse button, Excel applies all the formatting used in the example cell to all the cells you just 

selected!  

To keep the Format Painter selected so that you can format a bunch of different cell ranges with the Format Painter 

pointer, double-click the Format Painter button after you select the sample cell with the desired formatting. To stop 

formatting cells with the Format Painter pointer, you simply click the Format Painter button (it remains depressed when 

you double-click it) again to restore the button to its undepressed state and return the mouse pointer to its normal thick, 

white-cross shape.  

 

Recording macros in Excel 

To record a macro in Excel, follow these steps: 

1. Choose Tools --> Macro --> Record New Macro. 

A Record Macro dialog box appears. 

2. Type a name for your macro in the Macro name text box. 

3. Click in the Shortcut Key box (the one that has Ctrl+ to the left) and type a letter. 

For example, if you want to replay your macro by pressing Ctrl+W, type W in the Shortcut Key box. 

4. Click OK. 

A Stop Recording toolbar appears. 

5. Press the keystrokes that you want to record in your macro. 

6. Click the Stop Recording button when you finish recording the keystrokes. 

To run a macro, press the keystroke combination that you chose in 

 
 
 

 
 
 
 

 
 
 

By password-protecting your Excel workbook, you can prevent unauthorized users from opening 
and/or editing the workbook. You set a password for opening the workbook file when you're dealing 
with a spreadsheet whose data is of a sufficiently sensitive nature that only a certain group of people 
in the company should have access to it (such as spreadsheets dealing with personal information 
and salaries). Of course, after you set the password required in order to open the workbook, you 
must supply this password to those people who need access in order to make it possible for them to 
open the workbook file. 

 

Password-Protecting an Excel 2003 File  
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You set a password for modifying the workbook when you're dealing with a spreadsheet whose data 
needs to be viewed and printed by different users, none of whom are authorized to make changes to 
any of the entries. For example, you might assign a password for modifying to a workbook before 
distributing it companywide, after the workbook's been through a complete editing and review cycle 
and all the suggested changes have been merged. 

If you're dealing with a spreadsheet whose data is of a sensitive nature and should not be modified 
by anyone who's authorized to open it, you need to set both a password for opening and a password 
for modifying the workbook file. You assign either one or both of these types of passwords to a 
workbook file at the time you save it with the File --> Save As command on the Excel menu bar. 

When you choose this command (or choose the File --> Save command for a new file that's never 
been saved before), Excel opens the Save As dialog box. You can then set the password to open 
and/or the password to modify the file by taking these steps: 

1. Click the Tools pop-up button in the Save As dialog box and then click General Options 
on the pop-up menu. 

Doing this opens the Save Options dialog box where you can enter a password to open and/or a 
password to modify. When entering a password, it can be up to 255 characters long and consist of 
a combination of letters and numbers with spaces. When using letters, however, keep in mind that 
passwords are case-sensitive, so opensesame and OpenSesame are not the same password 
because of the different use of upper- and lowercase letters. 

 

When entering a password, make sure that you don't enter something that you can't easily 
reproduce or, for heaven's sake, that you can't remember. You must be able to immediately 
reproduce the password in order to assign it, and you must be able to reproduce it later if you ever 
want to be able to open or change the darned workbook ever again. 

2. (Optional) If you want to assign a password to open the file, type the password (up to 
255 characters maximum) in Password to Open text box. 

As you type the password, Excel masks the actual characters you type by rendering them as 
asterisks (*) in the text box. 

By default, Excel assigns an Office 97/2000 Compatible type encryption when you assign a 
password to open the file. You can use the Advanced button to assign another type of encryption 
for password-protecting the opening of the file. You should not, however, fool with these options 
unless you know what you're doing or have been instructed to use another type by someone in 
your IT department. 

If you decide to assign a password for opening and modifying the workbook at the same time, 
proceed to Step 3. Otherwise, skip to Step 4. 

When entering the password for modifying the workbook, you want to assign a password that's 
different from the one you just assigned for opening the file (if you did assign a password for 
opening the file in this step). 

3. (Optional) If you want to assign a password for modifying the workbook, click the 
Password to Modify text box and then type the password for modifying the workbook 
there. 

Before you can assign a password to open the file and/or to modify the file, you must confirm the 
password by reproducing it in a Confirm Password dialog box exactly as you originally entered it. 

4. Click the OK button. 

Doing this closes the Save Options dialog box and opens a Confirm Password dialog box, where 
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you need to exactly reproduce the password. If you just entered a password in the Password to 
Open text box, you need to reenter this password in the Confirm Password dialog box. If you just 
entered a password in the Password to Modify text box, you need only to reproduce this password 
in the Confirm Password dialog box. However, if you entered a password in both the Password to 
Open text box and the Password to Modify text box, you must reproduce those passwords. In the 
first Confirm Password dialog box, enter the password you entered in the Password to Open text 
box. Immediately after you click OK in the first Confirm Password dialog box, the second Confirm 
Password dialog box appears, where you reproduce the password you entered in the Password to 
Modify text box. 

5. Type the password exactly as you entered it in the Password to Open text box (or 
Password to Modify text box, if you didn't use the Password to Open text box), and then 
click OK. 

If your password does not match exactly (in both characters and case) the one you originally 
entered, Excel displays an alert dialog box, indicating that the confirmation password is not 
identical. When you click OK in this alert dialog box, Excel returns you to the original Save 
Options dialog box where you can do one of two things: 

• Reenter the password in the original text box. 

• Click the OK button to redisplay the Confirm Password dialog box, where you can try again to reproduce the 
original. (Make sure that you've not engaged the Caps Lock key by accident.) 

If you assigned both a password to open the workbook and one to modify it, Excel displays a 
second Confirm Password dialog box as soon as you click OK in the first one and successfully 
reproduce the password to open the file. You then repeat Step 5, this time, exactly reproducing 
the password to modify the workbook before you click OK. 

When you finish confirming the original password(s), you are ready to save the workbook in the 
Save As dialog box. 

6. (Optional) If you want to save the password-protected version under a new filename or in 
a different folder, edit the name in the File Name text box and then select the new folder on 
the Save In drop-down list. 

7. Click the Save button to save the workbook with the password to open and/or password 
to modify. 

As soon as you do this, Excel saves the file if this is the first time you've saved it. If not, the 
program displays an alert dialog box indicating that the file you're saving already exists and asking 
you if you want to replace the existing file. 

8. Click the Yes button if the alert dialog box that asks if you want to replace the existing 
file appears. 
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Saving a Static Web Page in Excel 2002  

 

The concept of publishing Excel spreadsheet data on the World Wide Web makes a heck of a lot of 
sense, both from the standpoint of the worksheet's tabular layout and the worksheet's calculated 
contents. As anyone who's tried to code an HTML (HyperText Markup Language) table will tell you, 
this is one of the nastiest jobs a person can perform. Even creating the simplest HTML table is a pain 
because you have to use <TH> and </TH> tags to set up the column headings in the table along with 
<TR> and </TR> tags to set up the rows of the table, and <TD> and </TD> tags to define the 
number and width of the columns — as well as what data goes in each cell of the table. 

Excel enables you to create Web pages that display your worksheet data in either a static, look-but-
don't-touch mode, or an interactive, let's-have-some-fun mode. When you create a Web page with 
static worksheet data, your users can view the Excel data only with their Web browsers. When you 
create a Web page with interactive worksheet data, however, your users can continue to play around 
with the data by editing and formatting its values. Depending upon the nature of the spreadsheet, 
your users can even continue to perform calculations and, in cases of data lists, manipulate the data 
by sorting and filtering it. 

To create a static Web page, you follow these general steps: 

1. Open the workbook with the data to be saved as a Web page. 

2. (Optional) When saving something less than the entire workbook or entire current 
worksheet, select the item of cells. If you're inserting a chart, click the chart. If you're 
inserting a range of cells, select the range. 

If you know that you want to save a particular chart or particular range of cells of a worksheet in 
the new Web page, you should select the chart to be saved before you open the Save As dialog 
box (see Step 3). Selecting the chart ahead of time changes the Selection: Sheet radio button to 
the Selection: Chart radio button. In the case of a cell range selection, the Selection: Sheet radio 
button changes to a Selection: radio button followed by the address of the cells selected. 

3. Choose File-->Save as Web Page from the menu bar to open the Save As dialog box. 

4. Indicate which part of the workbook is to be saved in the new Web page. 

To save the contents of all sheets in the workbook, make sure that the Entire Workbook radio 
button is selected. To save only the data in the current worksheet, choose the Selection: Sheet 
radio button instead. Note: If you clicked the chart in the worksheet that you intend to convert into 
a Web page graphic before opening the Save As dialog box, you need to choose the Selection: 
Chart radio button (which replaces the Selection: Sheet button). If you selected a cell range, you 
need to choose the Selection: radio button followed by the address of the selected cell range. 

To save the contents of a worksheet other than the one currently selected, click the Publish button 
and then choose the sheet by its description from the Choose drop-down list box. 

To save a chart that you didn't select prior to opening the Save As dialog box, click the Publish 
button and then select the chart (identified by its description) from the Choose drop-down list. 

To save a specific range of cells that you didn't select prior to opening the Save As dialog box, 
click the Publish button. Then, select Range of Cells from the Choose drop-down list before you 
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type the range address in the text box immediately below or enter it by selecting the range of cells 
by highlighting them in the worksheet. 

5. Specify a filename for the new Web page. 

Enter the name for the new Web page in the File Name text box. Note that Excel appends the 
filename extension .htm (which stands for HyperText Markup, indicating that this is an HTML text 
file) to whatever filename you enter in this text box. If you plan to publish the Web page on a UNIX 
Web server, keep in mind that this operating system is sensitive to uppercase and lowercase 
letters in the filename. (The Macintosh and Windows operating system are both case-blind when it 
comes to filenames.) 

6. Designate the location where the Web page is to be saved. 

When saving the new Web page on your computer's hard drive or even a network drive, you need 
to indicate the drive and directory in the Save In text box just as you do when saving a regular 
Excel workbook file. To save the page to a folder: 

To save the new Web page directly on your company's Internet or intranet Web site, click the 
Web Folders button and then open the folder in which you want the page saved. 

To save the new page on an FTP (File Transfer Protocol) site that your Web administrator or 
favorite IT person has set up, select FTP Locations from the Save In drop-down list box and 
then open the FTP folder in which you want the page saved. 

In both cases, you (or a qualified Web-head) must have already set up the Web folders or FTP 
locations before you can save your worksheet Web pages there. 

7. (Optional) Specify a title for the Web page. 

If you want Excel to add a title (which appears centered at the top of the page before any of the 
data or charts), click the Change Title button in the Save As dialog box. Type the text for the title 
in the Set Page Title dialog box and click OK. Note that you can also add or edit a title with the 
Change Title button in the Publish as Web Page dialog box (which you open by clicking the 
Publish button in the Save As dialog box). 

8. Save the Web page. 

To save your new Web page using the settings you designate in the previous steps, select the 
Save button in the Save As dialog box. If you want to preview your Web page immediately upon 
saving it, click the Publish button to open the Publish as Web Page dialog box. Next, select the 
Open Published Web Page in Browser check box before you click the Publish button or press 
Enter. 

Note: Upon saving your worksheet data in the new Web page, Excel automatically creates a new 
folder with the same name as the .htm file that contains all the supporting files, including such things 
as the graphics files and charts among the numerical data. Thus, if you move the Web page from a 
local drive to a Web server of sort, you need to copy the supporting files folder as well as its Web 
page file to ensure that the user's browser can successfully render the entire contents of the page. 

 

If you would prefer that Excel not create a separate folder with the supporting files, you can change 

this setting in the Web Options dialog box (opened by choosing  

Tools-->Options and then clicking the Web Options button on the General tab). In the Web Options 

dialog box, simply remove the check mark from the Organize Supporting Files in a Folder check box 

on the Files tab. 

Note, too, that when you save an entire workbook containing worksheet data and charts on separate 
worksheets, the Internet Explorer preserves the original Excel sheet arrangement in the resultant 
static Web page by adding sheet tabs at the bottom of the Internet Explorer's window. 
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Inserting Special Symbols  

 

Excel 2003 makes it easy to enter special symbols, such as foreign currently indicators, as well as special characters, such as 

Trademark and Copyright symbols, into your cell entries. To insert a special symbol or character in a cell entry, choose Insert, Symbol 

on the Excel menu bar.  

When you choose this command the Symbol dialog box appears. This dialog box contains two tabs: Symbols and Special Characters. 

To insert a mathematical or foreign currency symbol on the Symbols tab, click its symbol in the list box and then click the Insert 

button; you can also just double-click the symbol. You can view different subsets of symbols by choosing a subset from the Subset 

pull-down menu.  

To insert special characters, such as Registered Trademark or ellipses, click on the Special Characters tab and follow the same 

procedure.  

 

Transient Toolbars 

Normally, the Standard and Formatting toolbars appear side by side on the second bar at the top of the Excel program in 

a stationary position politely referred to as being in a docked position. Although, Excel automatically docks these toolbars 

together at the top of the screen, you are free to move them (as well as other toolbars that you open) around by dragging 

them into new positions.  

When you drag the Standard or Formatting toolbar down from its perch and into the work area containing the open 

workbook, the toolbar then appears in a separate little window. Such toolbars-in-a-window are referred to as floating 

toolbars because they float like clouds above the open workbook below (how poetic!). And not only can you move these 

little dears, but you can resize them as well:  

 You can move a floating toolbar into new positions over the worksheet document by dragging it by its tiny title bar.  

 You can resize a floating toolbar by dragging any one of its sides. Wait until the mouse pointer changes to a 

double-headed arrow before you start dragging.  

 To close a floating toolbar when you no longer want it in the document window, click the Close box (the small box 

in the upper-right corner of the toolbar window). 
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